Router Charts

Click for Router Charts

Router Ranker

Click for Router Ranker

NAS Charts

Click for NAS Charts

NAS Ranker

Click for NAS Ranker

More Tools

Click for More Tools

Wireless Features

Introduction

The last time I looked at how a new generation of routers handled mixes of old and new clients was back in 2007. (Yikes!) Add, Don't Replace When Upgrading to 802.11n took a pretty simple approach by having 802.11n and 802.11g clients throw data full blast at a few routers.

Under those conditions, I found that both N and G clients could both take around a 50% throughput hit. As a result, I recommended that folks upgrading to N gear leave their old G router in place (converted to an access point) to handle G clients and use the N router only for N clients.

Of course, most N router buyers didn't follow that advice and their wireless LANs didn't grind to a halt, mainly because most of us don't load our WLANs to the breaking point. So I later amended my recommendation to advise keeping a G access point on the network only if you have a lot of A or G clients and they are very / constantly active, as in streaming or Torrenting.

For this look at how 802.11ac routers handle mixes of AC and older-generation clients, I took a more sophisticated approach. I ran my usual set of IxChariot-at-full-blast tests. But I also ran the same tests with throughput caps in place to give the router and clients some breathing room. The results were interesting.

The Gear

The test router for this experiment was a NETGEAR R7000 "Nighthawk" [reviewed] loaded with V1.0.2.194_1.0.15 firmware. There was no particular reason for choosing this router other than I had it on hand.

The Mixed AC Test Gear

I used four test clients with the router, representing four wireless classes:

  • AC867: Acer Aspire S7-392 running Win 8.1 64 bit with NETGEAR A6200 AC1200 adapter [reviewed] with 1.0.0.26 utility and 6.30.145.30 driver. The Acer's internal Intel Wireless-N 7260 adapter was disabled.
  • N450: Lenovo X220i running Win 7 Home Premium SP1 64 bit with Intel Centrino Ultimate N 6300 AGN adapter using 15.4.1.1 driver.
  • N150: Apple iPad (Gen 2) running iOS 7.0.4. This has a 1x1 a/b/g/n (N150) radio using a Broadcom BCM43291.
  • A54 (802.11a): Fujitsu P7120 Lifebook running Win XP SP2 with Intel Pro Wireless 2915AGB adapter and 9.0.2.25 driver

The class indications shown are the maximum link rates for each device with a 5 GHz connection and the router set to 80 MHz bandwidth mode. Note the iPad is identified in the plots as "N65" because its low throughput led me to believe that it was operating in 20 MHz bandwidth mode, not 40 MHz mode. 40 MHz mode is required to support the full 150 Mbps link rate for a 1x1 N device.

The Tests - 40 Mbps Cap

I ran tests using IxChariot's throughput.scr script with TCP/IP and test file sizes adjusted to the throughput rates of the different adapters. I set file sizes to provide a good look at short term variation, typically between 500,000 Bytes for A54 and 5,000,000 Bytes for N450 and AC1200.

The router and all four clients were set up in my home office with all clients within 10 feet of the router. Tests were run with the router set to channel 153, uplink only (data flowing from client to router) using open-air testing. No other networks were operating during the tests.

As noted earlier, tests were run both with each test stream data send rate limited to 40 Mbps and then with no send rate limit. Let's look at the capped test results first. I started by taking baseline measurements of each client running by itself. The results are shown in the composite IxChariot plot below.

Composite plot of individual tests - 40 Mbps data rate cap

Composite plot of individual tests - 40 Mbps data rate cap

Both the AC and N450 devices were able to hit the 40 Mbps cap, but neither the N150 nor A54 devices could. This was expected for the 802.11a device, since typical maximum throughput with a 54 Mbps link rate is only in the mid-20 Mbps range. But the iPad should have been able to support 40 Mbps if it were linked at the full 150 Mbps it is capable of in 5 GHz.

Unfortunately, I have no idea what the iPad's link rate was, since Apple treats this information like a state secret. iOS doesn't show it and there is no app that displays this information. The R7000 router wasn't any help either, since it doesn't show wireless client connection link rate (or signal level). I can say the Fujitsu notebook Windows Network Connection properties showed a solid 54 Mbps link rate.

I then ran all four clients simultaneously to generate the second plot below. Note the significantly higher throughput variation in the AC867 and N450 plots.

Composite plot of individual tests - 40 Mbps data rate cap

Composite plot of simultaneous tests - 40 Mbps data rate cap

I pulled each client's throughput for both tests into the table below and calculated the difference. The lowest difference was seen in the N65 device, while the highest was in the A54. Overall, running all four client types at once resulted in a 27% throughput loss.

Client Class Individual Simultaneous % Difference
AC867 39.6 35.3 -11
N450 38.1 28.2 -26
N150 12.6 12.4 -1
A54 17.2 2.4 -86
Total 107.5 78.3 -27
Table 1: Bandwidth Loss - 40 Mbps data rate cap

More Wireless

TRENDnet logo

How Powerline Can Solve Your Wi-Fi Woes - There's a better way to get WiFi Everywhere™.

Wi-Fi System Tools
Check out the new Wi-Fi System Charts, Ranker and Finder!

Featured Sponsors


Support Us!

If you like what we do and want to thank us, just buy something on Amazon. We'll get a small commission on anything you buy. Thanks!

Over In The Forums

First post, so please be gentle...I have a ReadyNAS Ultra6 in RAID6 (6 x 2TB) to store 2-3TB of family videos/photos/etc from a PC. I use a ReadyNAS D...
I currently have an RT-AC68U with a cpu at 800MHz and was wondering if anyone had upgraded theirs from one at 800MHz to one natively at 1GHz, without ...
We run multiple PC's for MMO's and stream to TV's from our Plex server. Comcast 55/5.Running AC usb on all PC's except the Plex server which is Cat co...
Hi,I have some ghost issue hoping you could help me out. I got Asus RT-AC68U (TM-1900) exactly 1 year ago, and I follow this instruction to flash Firm...
Followed configs here on SNBForums and PIA site and was working fine for 6 months...Suddenly stopped and responds with "Error - check configuration!"/...

Don't Miss These

  • 1
  • 2
  • 3
Get Backblaze Now!