Router Charts

Router Charts

Router Ranker

Router Ranker

Router Chooser

Router Chooser

NAS Charts

NAS Charts

NAS Ranker

NAS Ranker

More Tools

More Tools

Wireless News

Amped Wireless logo Amped Wireless has announced a wall-plugged wireless range extender

The REC10 High Power 600mW Compact Wi-Fi Range Extender is a 2.4 GHz N300 range extender in a compact "wall-wart" style enclosure.

The extender supports WEP, WPA and WPA2 wireless security, Wi-Fi Protected Setup and works with all wireless routers.

It can also function as a wireless bridge, connecting any Ethernet device via its 10/100 Ethernet port.

Like many Amped Wireless products, the REC10 has dual 600mW transmit and dual low noise receive amplifiers. One external antenna is upgradeable but the second internal antenna is not.

Amped Wireless REC10 High Power 600mW Compact Wi-Fi Range Extender

Amped Wireless REC10 High Power 600mW Compact Wi-Fi Range Extender

The REC10 is available now direct from Amped Wireless for $79.99 MSRP and shortly in general distribution.

More Wireless

Featured Sponsors

Support Us!

If you like what we do and want to thank us, just buy something on Amazon. We'll get a small commission on anything you buy. Thanks!

Top Performing Routers

AC3200
AC2600
AC1900
AC1750
AC1200

Top Performing NASes

NoRAID
RAID1
RAID5

Over In The Forums

I looked at router benchmarks and even a very good router has its maximum ethernet speed less than gigabits speed (500-800Mbps). So if I want to buy ...
I am running an RT-AC66U with firmware 380.58 and the some of the client names (and vendor names) are completely garbled in the network map.
Hello, I got in early today to install an ERL3 before anyone else made it into the office. Now I'm stuck. I reset my ERL3 and then via Restore Config...
so you see nothing in the site survey passive or active :¬) Model RT-AC5300 Firmware Version 380.59_beta2-gda78c52 Firmware Build Sat Apr 30 20:23:20...
Hello everyone! I hope someone might have some advice for me here; I have a miniPC device which apparently has an issue getting an IP when connected...

Don't Miss These

  • 1
  • 2
  • 3