Like every other website on the planet, SmallNetBuilder uses cookies. Our cookies track login status, but we only allow admins to log in anyway, so those don't apply to you. Any other cookies you pick up during your visit come from advertisers, which we don't control.
If you continue to use the site, you agree to tolerate our use of cookies. Thank you!

Router Charts

Click for Router Charts

Router Ranker

Click for Router Ranker

NAS Charts

Click for NAS Charts

NAS Ranker

Click for NAS Ranker

More Tools

Click for More Tools

NAS News

Seagate logoSeagate says shipments of its Business Storage NASes have not been halted.

Seagate told SmallNetBuilder its initial communication saying shipments of all its new Business Storage NASes had been suspended was in error.

The company asked us to post the following correction:

Seagate continues to actively ship and promote our Business Storage products. During the review process, Seagate became aware of lower than planned USM data transfer speeds. An automatic update will be released in the upcoming weeks to all existing Business Storage customers.

More NAS

Wi-Fi System Tools
Check out our Wi-Fi System Charts, Ranker and Finder!

Support Us!

If you like what we do and want to thank us, just buy something on Amazon. We'll get a small commission on anything you buy. Thanks!

Over In The Forums

My GT-AC5300 is only getting between 50mbps and 150mbps. I have a gigabit connection. From the modem directly, I get 900mbps. I've changed cables and ...
Hi folks, Wondering if you're able to help. Recently upgraded from the ISP-provided router for our gigabit fibre to the Asus RT-AC86U. With the defaul...
So, this is a thing that has bugged me for a long time. When I am on the Network Map page, I see the clients connected with 31 connected clients. Then...
I ran into this issue early today and figure to upgrade the firmware to 384.8_2 since it is available (hoping that fixes the issue)...But I still can ...
Hi..This is related to Asus RT-AC88U firmware version 384.8_2 but I always get "Cannot assign requested address" and "Failed to get IP for interface e...

Don't Miss These

  • 1
  • 2
  • 3