Like every other website on the planet, SmallNetBuilder uses cookies. Our cookies track login status, but we only allow admins to log in anyway, so those don't apply to you. Any other cookies you pick up during your visit come from advertisers, which we don't control.
If you continue to use the site, you agree to tolerate our use of cookies. Thank you!

Router Charts

Click for Router Charts

Router Ranker

Click for Router Ranker

NAS Charts

Click for NAS Charts

NAS Ranker

Click for NAS Ranker

More Tools

Click for More Tools

Specs and Design Info

As mentioned earlier, the WSKP100 is manufactured by SMC's parent company Accton and will also appear as the EdgeCore WM4201 and Belkin F1PP000GN-SK. A close comparison of the phone with photos of the Netgear phone, however, confirms that the SPH101 is not the same design.

The phone came in a box marked with an "smc-asia.com" URL and had neither the Wi-Fi mark shown in Figure 1, nor any FCC ID marking. So I got out my dissection kit and opened it up. Figure 2 shows that the design is based around a TI OMAP 1710 single-chip cell phone application processor.

The other larger chips visible in the photo are:

  • TI TPS65013 Multi-Channel 1-cell Li-Ion Power Management chip
  • TI TSC2101 Audio Codec w/ Integrated Headphone Speaker Amp & Touch Screen Controller
  • Samsung K4S54163 256Mbit SDRAM
  • Intel Z422070C (couldn't find this)

WSKP100 board

Figure 2: WSKP100 board (click image to enlarge)

I didn't remove the board from the case, since it seemed to resist my gentle efforts. So I didn't get a look at the other side of the board. I suspect all that I would see, however, is the 1.8"CSTN, 65K color 128 x 160 LCD screen with LED backlight and keypad contacts. Also not shown in the picture is a buzzer that nestles in the back cover for the phone's silent vibrate mode.

I also didn't remove the shield over the radio section, but given the other TI components, I'm guessing I'd find a TI WL1251 WiLink 4.0 single-chip 802.11b/g radio. The SMC User Guide specs the phone's radio at a decent RF output power of 16 dBm (40 mW) for 802.11b and 12 dBm (16 mW). This, coupled with a 5.5 dBi antenna helped to give the phone decent range (more later).

The phone is powered by a removable Li-Ion 3.7 V minimum 1100 mAH battery that the phone's User Guide said will supply "Use Time: 3 hrs" and a standby time of 50 hrs. However, I got nowhere near that in a couple of days of use with overnight recharges in between. I found that the phone was pretty much tapped out after about 8 hours of standby and perhaps 15 minutes of calling.

The User Guide says the battery will fully charge in three hours, but the charge indicator that appeared on the phone screen never showed higher than a half charge. However, when the phone was powered up, the battery indicator on the Main screen showed a full charge. One other battery-related issue is that I found the back cover a bear to open with the battery inserted. I had to pry it open using a screwdriver, which fortunately didn't seriously damage the relatively-thin battery compartment cover.

Finally, while browsing through the Settings > Information menu, I came upon a "Powered by TrollTech.com" logo. So I guess it's safe to assume one of TrollTech's products is at work in the WSKP100.

Wi-Fi System Tools
Check out our Wi-Fi System Charts, Ranker and Finder!

Support Us!

If you like what we do and want to thank us, just buy something on Amazon. We'll get a small commission on anything you buy. Thanks!

Over In The Forums

Update 2020/11/12 (9.0.0.4.386.40947)https://drive.google.com/drive/folders/1UHZwR1buG-nei8fne9d9OktOS2gZy6Hs?usp=sharingThis version includes 19 mode...
Hi AllHopefully this is the right place to post...My DSL-AC68U running 384.17_0-gnuton1/atmt (packages below) periodically disconnects from broadband....
https://onedrive.live.com/?authkey=!AGY2taGX02nVmWA&id=CCE5625ED3599CE0!1427&cid=CCE5625ED3599CE0@RMerlin @thiggins is it possible to have "Alpha" pre...
I had this working for several years and it just recently stopped after I had to reset my router. I thought I had everything set up correctly but I gu...
two separate issues (second redundant with a post on the general forum):1. has anyone made a warranty claim with Asus before? have you received any ob...

Don't Miss These

  • 1
  • 2
  • 3